Phone access to Customer Care Team is disrupted
Incident Report for Bizzabo
Resolved
We have resolved this issue, and phone support is functioning properly!
Posted Mar 29, 2023 - 13:46 EDT
Investigating
The phone service to the Bizzabo Customer Care Team (formerly known as Customer Support) is not allowing calls to come through. We are working with our 3rd party vendors to investigate and resolve this issue.
Posted Mar 28, 2023 - 16:56 EDT
This incident affected: Organizer Dashboard, Events Websites, API, Virtual - Interact, Virtual - Stream, Agenda, Registration, Email, The Venue, Website Editor, and Onsite Command Application.