The Venue is experiencing temporary issues
Incident Report for Bizzabo
Resolved
We're pleased to report that we have the all-clear, and all functionality is now restored. The Venue is up and running. We apologize for the inconvenience this may have caused you.
Posted Jun 15, 2022 - 12:07 EDT
Monitoring
Our team has identified and fixed the issue. We are still monitoring the system to ensure all functionality is restored. We appreciate your patience.
Posted Jun 15, 2022 - 11:50 EDT
Investigating
We are receiving reports of service disruption, and the Venue services may not be accessible.
Our R&D team is actively investigating the issue. Thank you for being so patient, and sorry for the disruption.

We will send an additional update within 15 minutes.
Posted Jun 15, 2022 - 11:39 EDT
This incident affected: Events Websites.