Service disruption
Incident Report for Bizzabo
Resolved
The incident was resolved,
All services are back to normal.
Posted Sep 25, 2019 - 07:52 EDT
Update
We are continuing to investigate this issue.
Posted Sep 25, 2019 - 07:50 EDT
Investigating
We’re experiencing a service disruption and are currently looking into the issue. The good news is we are taking immediate action to ensure everything is back up as soon as possible
Posted Sep 25, 2019 - 07:50 EDT
This incident affected: Organizer Dashboard, Events Websites, and API.