The reporting hub on Bizzabo dashboard is not accessible - RESOLVED
Incident Report for Bizzabo
Resolved
This issue has been resolved with reporting now available.
Posted Apr 12, 2023 - 13:56 EDT
Identified
Looker is currently experiencing issues; hence Bizzabo reporting is temporarily inaccessible. Our customers' account data is not affected.
Posted Apr 12, 2023 - 06:43 EDT
This incident affected: Organizer Dashboard.