Service Degradation - Delays in processing registrations and accessing dashboards
Incident Report for Bizzabo
Resolved
R&D continues to monitor the performance gains from changes made to the platform yesterday. Since those changes were made, we have not seen the recurrence of any data queueing which resulted in the latency issues experienced this week.

Our monitoring of system performance is ongoing and we will mark this as resolved. We appreciate your patience as we’ve worked to remedy this incident. If there is anything we can do to address this issue or any other, please open a ticket with our support team.
Posted Apr 15, 2022 - 16:04 EDT
Update
Our R&D team has worked through the night to address the latency issues experienced on our platform. They have been able to resolve the latency currently.

We will keep this incident in a "Monitoring" state through today, and will provide an update by the close of business (EST) as to this being resolved. Thank you again for your patience.
Posted Apr 15, 2022 - 09:14 EDT
Monitoring
We appreciate your patience over the past 24 hours as we worked to identify the root cause and scope of changes needed to address the reported issues around latency and overall dashboard performance. We are pleased to announce that the root cause of the issue has been identified, latency has been reduced without any data loss, and we are implementing changes to eliminate this issue over the next few days. We will keep this incident in a "Monitoring" state until we have a full resolution.
Posted Apr 14, 2022 - 10:33 EDT
Update
We are continuing to investigate the delays in processing and accessing various areas of the platform. There is no loss of data, all registrations and confirmation emails will be processed once we have resolved this issue. We appreciate your patience, and will update again more information is available.
Posted Apr 13, 2022 - 16:50 EDT
Investigating
We are currently working to resolve an issue which is creating delays in processing registrations and accessing dashboards. We can confirm no data is being lost, but we are working quickly to remedy the delays we are seeing related to registrations showing up in the platform, confirmation emails being sent, and dashboards loading. We will update again as soon as we have more information to share.
Posted Apr 13, 2022 - 13:10 EDT
This incident affected: Organizer Dashboard, API, Registration, and Email.