Delays with Registration Identified
Incident Report for Bizzabo
Resolved
This incident has been resolved.
Posted Mar 02, 2023 - 15:59 EST
Update
We are continuing to work on a fix for this issue.
Posted Mar 02, 2023 - 15:58 EST
Identified
A carry-over from our prior event, we have identified a slight delay in processing registrations on the platform. We have made the needed changes, and the service is returning to normal. We will set this to a "Monitoring" status for now and will report back once the incident is fully resolved.
Posted Mar 02, 2023 - 15:30 EST
This incident affected: Registration.