Heavy load
Incident Report for Bizzabo
Resolved
This incident has been resolved.
Posted May 14, 2018 - 17:05 UTC
Identified
The Bizzabo platform is experiencing heavier than anticipated usage, this has caused some of our services to perform slower than usual. The good news is we are taking immediate action to ensure everything is back up as soon as possible.
Posted May 14, 2018 - 16:47 UTC
This incident affected: Organizer Dashboard, Events Websites, and API.