Heavy load
Incident Report for Bizzabo
Resolved
This incident has been resolved.
Posted May 15, 2018 - 15:54 UTC
Identified
We are experiencing heavy load and working on resolving it
Posted May 15, 2018 - 15:54 UTC
This incident affected: API.