Service Degradation

Incident Report for Bizzabo

Resolved

This incident has been resolved.
Posted 5 years ago. Dec 16, 2020 - 04:32 EST

Investigating

We are currently investigating the issue
Posted 5 years ago. Dec 16, 2020 - 04:24 EST
This incident affected: Events Websites, Virtual - Interact, and Virtual - Stream.