Cloudflare incident is causing intermittent errors when accessing Bizzabo

Incident Report for Bizzabo

Resolved

We're happy to report that the Cloudflare incident has been resolved, and everything is back to normal. We apologize for any inconvenience this may have caused and appreciate your patience. Please let us know if you have any further questions or concerns.
Posted Nov 18, 2025 - 12:46 EST

Update

We have implemented a solution and are actively monitoring the situation to ensure that everything is running smoothly. We will continue to keep a close eye on things and will provide any necessary updates. Thank you for your patience and understanding.
Posted Nov 18, 2025 - 07:32 EST

Monitoring

The Bizzabo platform has returned to normal operation. We’re closely monitoring performance and error rates while Cloudflare continues its incident response. If you still experience issues, please contact support@bizzabo.com. We’ll share another update shortly.
Posted Nov 18, 2025 - 07:20 EST

Identified

We’ve identified that a broader Cloudflare incident is causing intermittent 503 errors when accessing Bizzabo. Our engineering team is actively implementing mitigations to route around/temporarily disable Cloudflare in affected regions. You can follow the Cloudflare status page here: https://www.cloudflarestatus.com/. Thank you for your understanding, and please don't hesitate to reach out to support@bizzabo.com with any additional concerns.
Posted Nov 18, 2025 - 07:02 EST
This incident affected: Organizer Dashboard, Events Websites, API, Virtual - Interact, Virtual - Stream, Agenda, Registration, Email, The Venue, Website Editor, and Onsite Command Application.