Service Degradation - Dashboard Latency & Registration Delays
Incident Report for Bizzabo
Resolved
We appreciate your patience as we worked through this incident and apologize for the inconvenience it caused. We are marking this issue as resolved. Should you have any questions or need additional assistance, please reach out to Bizzabo Support.

A formal Root Cause Analysis is being worked on and once ready, will be available via Bizzabo Support or your Customer Success Manager.
Posted Apr 26, 2022 - 08:13 EDT
Update
We are continuing to monitor for any further issues.
Posted Apr 24, 2022 - 17:06 EDT
Monitoring
With the successful maintenance window complete, we are setting this status to "Monitoring" until the system processes the items that were generated during the maintenance window. This may take several hours and we will mark this Resolved once this is caught up.
Posted Apr 24, 2022 - 17:05 EDT
Update
To fully address the latency issues we have been experiencing, we will need to implement a window for platform maintenance, beginning Saturday, 4/23, at 10 pm EST, until Sunday, 4/24, at 5 pm EST. During this time, the Bizzabo platform will be partially unavailable and both the dashboard and registration will not be functional. We apologize for any inconvenience this may cause. Should you need any assistance or information around this maintenance event, please reach out to Bizzabo Support.
Posted Apr 21, 2022 - 20:35 EDT
Update
We continue to work with our engineering team to provide both a comprehensive timeline for resolution, as well as a clear outline of the expected impact on product functionality during that process. A formal letter will be emailed to all users, with an update posted here once it is ready. Your continued patience is greatly appreciated as we work to bring about both a full resolution and detailed communication around next steps.
Posted Apr 21, 2022 - 10:17 EDT
Identified
Our Engineering team has identified a path forward to resolve the latency issues. We are finalizing the details of the plan and will communicate them tomorrow morning. We apologize for the delay in sharing out the full plan, but we are working diligently to ensure that we resolve every possible iteration of this issue. Once we have finalized all details of the steps we will take, we will communicate them here by tomorrow morning (EST).
Posted Apr 20, 2022 - 18:07 EDT
Update
R&D continues to work on immediate improvements to the current dashboard latency, and are working on several options to bring about a full remedy to this incident. A detailed update will be posted by the end of the day.
Posted Apr 20, 2022 - 12:20 EDT
Update
We are continuing to investigate latency impacting dashboards, registrations, and post-registration actions (specifically the receipt of confirmation emails). We will provide additional updates as they become available.
Posted Apr 19, 2022 - 17:01 EDT
Update
In order to mitigate the current latency issues, we’ve temporarily disabled a capability in your Event Experience OS. The report tiles on dashboards will be turned off, but those found under “Analytics” will not be affected. We will restore these services as quickly as possible. If you have any questions, please open a ticket with Bizzabo Support.
Posted Apr 19, 2022 - 12:59 EDT
Investigating
We are investigating reports of latency which is primarily impacting organizer dashboards. We will update on our progress as soon as possible.
Posted Apr 19, 2022 - 11:20 EDT
This incident affected: Organizer Dashboard, API, Registration, and Email.