Disruption to scheduled email campaigns
Incident Report for Bizzabo
Resolved
This issue has been resolved. Full functionality has been restored to scheduled email campaigns. Please reach out to our Customer Care team at support@bizzabo.com if any questions arise.
Posted Apr 17, 2023 - 18:03 EDT
Monitoring
Our Engineering team has released the fix for the issue. We are monitoring the results.
Posted Apr 17, 2023 - 17:18 EDT
Identified
Our Engineering team has identified the issue regarding the disruption to scheduled email campaigns, and they are working to implement a resolution, which should be released on Tuesday. If you have a need to send scheduled campaigns prior to that, please reach out to the Customer Care Team.
Posted Apr 17, 2023 - 15:10 EDT
Investigating
We are currently investigating an issue with scheduled email campaigns. Our Engineering Teams are working to resolve the issue.
Posted Apr 17, 2023 - 12:39 EDT
This incident affected: Email.