The Bizzabo organizer dashboard is down.
Incident Report for Bizzabo
Resolved
We're happy to report that the issue has been resolved, and everything is back to normal. We apologize for any inconvenience this may have caused and appreciate your patience while we worked to resolve the issue. Please let us know if you have any further questions or concerns.
Posted Oct 18, 2023 - 07:44 EDT
Investigating
Our team is currently investigating the issue and gathering all relevant information. We will provide updates as soon as possible and appreciate your patience as we work towards a resolution.
Posted Oct 18, 2023 - 07:35 EDT
This incident affected: Organizer Dashboard and Events Websites.