Service Degradation
Incident Report for Bizzabo
Resolved
We're pleased to report that we have the all-clear, and all functionality is now restored. Thanks so much for bearing with us in the meantime.
Posted Apr 22, 2021 - 07:13 EDT
Monitoring
Event websites are now stable and we are monitoring for additional issues. Thanks for your patience.
Posted Apr 22, 2021 - 06:16 EDT
Identified
We are currently experiencing a service degradation and some of the platform components may not be accessible.
Our R&D team is working to identify the root cause and implement a solution.

We will send an additional update as soon as we have any news on the issue.
Posted Apr 22, 2021 - 05:56 EDT
This incident affected: Organizer Dashboard, Events Websites, Virtual - Interact, and Virtual - Stream.