Bizzabo Service Disruption
Incident Report for Bizzabo
Resolved
We're pleased to report that we have the all clear, and all functionality is now restored. Thanks so much for bearing with us in the meantime.
Posted Aug 20, 2020 - 21:24 EDT
Update
We are continuing to see latency with dashboards and event websites. Our team is working to release another update to increase stability. We will update again in 20 minutes.
Posted Aug 20, 2020 - 20:50 EDT
Monitoring
Our team has rolled out a fix to the issue. We are still seeing some latency and we are continuing to monitor the system. We will provide additional updates within 10 minutes.
Posted Aug 20, 2020 - 20:06 EDT
Update
Our team is still working to resolve the issue. Rest assured we have all hands on-deck working on a solution. We’ll share more news shortly.
Posted Aug 20, 2020 - 19:40 EDT
Identified
Our team has identified the root cause of the issue and is implementing a resolution. We expect the fix to be rolled out shortly.

We will provide an update within 10 minutes.
Posted Aug 20, 2020 - 19:17 EDT
Update
We are continuing to investigate this issue.
Posted Aug 20, 2020 - 18:47 EDT
Investigating
We are receiving reports of a service disruption and Bizzabo services may not be accessible.
Our R&D team is actively investigating the issue. Thank you for your patience and sorry for the disruption.

We will send an additional update within 10 minutes.
Posted Aug 20, 2020 - 18:42 EDT
This incident affected: Organizer Dashboard, Events Websites, and API.